To boot DSP and run DSP application from ARM.

Kamoolkar, Mugdha mugdha at ti.com
Fri Sep 26 03:30:58 CDT 2008


Naveena,

Currently, no, this is not supported. While you can build in PROC-only mode, it still expects a DSPLink component on DSP-side, which will do handshake with the ARM-side driver to indicate completion of DSP start. This DSPLink component requires some shared memory.

But DSPLink 1.60 (will be out before the end of October), will have support for this feature that you have mentioned. The PROC module can then be used in PROC-only mode, to load and start any non-DSPLink DSP executables also.

Regards,
Mugdha


________________________________
From: Naveena M. [mailto:naveena.m at nestgroup.net]
Sent: Friday, September 26, 2008 12:50 PM
To: Kamoolkar, Mugdha; davinci-linux-open-source at linux.davincidsp.com
Subject: RE: To boot DSP and run DSP application from ARM.

Thank you. If I am to use PROC section alone (to load and run)and no other communication mechanism (MSGQ, POOL ,CHL...), is there any dependency with memory configuration. ie. Is the DSPLINKMEM needed for PROC? Can I build the Dsplink driver with PROC alone?

Regards,
Naveena

________________________________
From: Kamoolkar, Mugdha [mailto:mugdha at ti.com]
Sent: Friday, September 26, 2008 10:49 AM
To: Naveena M.; davinci-linux-open-source at linux.davincidsp.com
Subject: RE: To boot DSP and run DSP application from ARM.

Naveena,

You can look into the hal (hardware abstraction layer) code within DSPLink sources as a reference for what you are attempting to do. It will have the right sequence of register settings.

Regards,
Mugdha


________________________________
From: davinci-linux-open-source-bounces at linux.davincidsp.com [mailto:davinci-linux-open-source-bounces at linux.davincidsp.com] On Behalf Of Naveena M.
Sent: Friday, September 26, 2008 10:20 AM
To: davinci-linux-open-source at linux.davincidsp.com
Subject: To boot DSP and run DSP application from ARM.
Hello,
            How can I load DSP and run DSP application from ARM.
I am not using the TI provided dsplink driver available with montavista.
The TI provided driver supports API calls and those use to run DSP application from ARM are PROC_setup ,PROC_Attach ,PROC_Load and PROC_start.

Now I am setting registers by running a firmware application and running on ARM side by connecting CCS using JTAG emulator.
What I did was, loaded the dsp binary in the desired location from ARM application. Then I set the resest for DSP module by setting PSC_MDCTL for DSP.
Then loaded DSPBOOTADDR with the starting address of the loaded code and took of the reset.

            The concept was, on reset, the DSP will start running from the reset address or DSPBOOTADDR. But the DSP code dint start running.
Is there any other configuration that I have to look into or consider while doing this?
Or What happens in PROC_start?

Regards,
Naveena
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://linux.omap.com/pipermail/davinci-linux-open-source/attachments/20080926/8ca0005e/attachment.htm


More information about the Davinci-linux-open-source mailing list